Index » PageStream Support » Amiga » Conked out!
Sign in to add a comment Pages: 1
2012-08-27 12:02:15 CT #1
Bart Mathias
From: United States
Registered: 2007-01-13
Posts: 320

All of a sudden my PageStream5.0..5.8 won't launch!

I launched it successfully several times yesterday in attempts to figure out
how to get it to come up on its own screen instead of Workbench. Later I
looked at the icon to reconfirm that it had no tooltypes, and tried to
launch it again. Lots of hard drive activity, which then ceases entirely.

After trying again this morning, I went to look at the debug file, but
obviously PageStream wasn't through with it yet--I couldn't open, copy, or
rename it. It did survive a reboot, to my relief, and here is what I found
at the end:

FT_Done_Face calling
FT_Done_Face returned
fontpath_update done
Duplicate font:TomHud file1:Fonts:_TrueType/TomHud.ttf
file2:Fonts:_TrueType/TomHudson.ttf

I had saved a debug.txt from October 2010 for some reason, so I compared the
above with the old one. It too included the above lines near the bottom,
but in addition there was this:

initapprsrc name:en_US theme:<NULL>
oldsyskey2newsyskey oldkey:29 -> 80000029
oldsyskey2newsyskey oldkey:28 -> 80000028
oldsyskey2newsyskey oldkey:28 -> 80000028
oldsyskey2newsyskey oldkey:20 -> 80000020
oldsyskey2newsyskey oldkey:21 -> 80000021
oldsyskey2newsyskey oldkey:22 -> 80000022
oldsyskey2newsyskey oldkey:23 -> 80000023
oldsyskey2newsyskey oldkey:21 -> 80000021
oldsyskey2newsyskey oldkey:24 -> 80000024
initapprsrc name:en_US theme:<NULL>

This seems to be a clue as to where the program is conking out, but I can't
interpret it.

I also ran Snoopy, which ends with:
00596 : PageStream5 : o.k. = ExamineFH("DejaVuSansMono-Bold.ttf") [11uS]
00597 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
[44uS]
00598 : PageStream5 : FAIL =
GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [324uS]
00599 : PageStream5 : o.k. =
Lock("Apps:pgs5058/UserPrefs/FontSubstitutionData",SHARED) [91uS]
00600 : PageStream5 : o.k. =
Open("Apps:pgs5058/UserPrefs/FontSubstitutionData",OLD) = [0x142ADAC4]
[64uS]
00601 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
[33uS]
00602 : PageStream5 : FAIL =
GetVar("APPLICATIONDATA",0x4FB957DC,512,0x00000000) [217uS]
00603 : PageStream5 : FAIL =
Lock("Apps:pgs5058/UserPrefs/KerningData",SHARED) [40uS]
00604 : PageStream5 : FAIL =
Open("Apps:pgs5058/Defaults/KerningData",OLD) = [0x00000000] [92uS]
00605 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
[33uS]
00606 : PageStream5 : FAIL =
GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [206uS]
00607 : PageStream5 : FAIL =
Lock("Apps:pgs5058/UserPrefs/TrackingData",SHARED) [44uS]
00608 : PageStream5 : FAIL =
Open("Apps:pgs5058/Defaults/TrackingData",OLD) = [0x00000000] [70uS]
00609 : PageStream5 : o.k. =
Lock("Apps:pgs5058/SoftLogik/Printers",SHARED) [64uS]
00610 : PageStream5 : o.k. = Examine("Printers") [11uS]
00611 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:ELF.LazyBinding",SHARED)
[34uS]
00612 : PageStream5 : o.k. =
LoadSeg_OVL("Apps:pgs5058/SoftLogik/Printers/PostScript.prt",0x00000000,0x00000000)
= [0x13
00613 : PageStream5 : -----> RunCommand(0x13C05C01
"Apps:pgs5058/SoftLogik/Printers/PostScript.prt",,"",0)
00614 : PageStream5 : 0 =
FindSegmentStackSize("Apps:pgs5058/SoftLogik/Printers/PostScript.prt")
[500uS]

I use PageStream frequently for minor things, but especially for one small
but important job each month during the school year. It's time for me to do
it, but...
--
Bart Mathias
SAM460ex OS4.1.5


2012-08-27 18:05:52 CT #2
admfubar
From: Unknown
Registered: 2011-11-19
Posts: 198

here is something to try... find the pagestream configuration dirctory, not sure where it is kept on amigas these days...
and rename it (like pagestreamold

then try launching pagestream, it should come up in demo mode, and if it does, that is a good sign, as it is just something in the configuration file that is a little wonky.

On Mon, 27 Aug 2012 18:02:15 -0400, Bart Mathias <mathias@hawaii.edu> wrote:

> All of a sudden my PageStream5.0..5.8 won't launch!
>
> I launched it successfully several times yesterday in attempts to figure out
> how to get it to come up on its own screen instead of Workbench. Later I
> looked at the icon to reconfirm that it had no tooltypes, and tried to
> launch it again. Lots of hard drive activity, which then ceases entirely.
>
> After trying again this morning, I went to look at the debug file, but
> obviously PageStream wasn't through with it yet--I couldn't open, copy, or
> rename it. It did survive a reboot, to my relief, and here is what I found
> at the end:
>
> FT_Done_Face calling
> FT_Done_Face returned
> fontpath_update done
> Duplicate font:TomHud file1:Fonts:_TrueType/TomHud.ttf
> file2:Fonts:_TrueType/TomHudson.ttf
>
> I had saved a debug.txt from October 2010 for some reason, so I compared the
> above with the old one. It too included the above lines near the bottom,
> but in addition there was this:
>
> initapprsrc name:en_US theme:<NULL>
> oldsyskey2newsyskey oldkey:29 -> 80000029
> oldsyskey2newsyskey oldkey:28 -> 80000028
> oldsyskey2newsyskey oldkey:28 -> 80000028
> oldsyskey2newsyskey oldkey:20 -> 80000020
> oldsyskey2newsyskey oldkey:21 -> 80000021
> oldsyskey2newsyskey oldkey:22 -> 80000022
> oldsyskey2newsyskey oldkey:23 -> 80000023
> oldsyskey2newsyskey oldkey:21 -> 80000021
> oldsyskey2newsyskey oldkey:24 -> 80000024
> initapprsrc name:en_US theme:<NULL>
>
> This seems to be a clue as to where the program is conking out, but I can't
> interpret it.
>
> I also ran Snoopy, which ends with:
> 00596 : PageStream5 : o.k. = ExamineFH("DejaVuSansMono-Bold.ttf") [11uS]
> 00597 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [44uS]
> 00598 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [324uS]
> 00599 : PageStream5 : o.k. =
> Lock("Apps:pgs5058/UserPrefs/FontSubstitutionData",SHARED) [91uS]
> 00600 : PageStream5 : o.k. =
> Open("Apps:pgs5058/UserPrefs/FontSubstitutionData",OLD) = [0x142ADAC4]
> [64uS]
> 00601 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [33uS]
> 00602 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957DC,512,0x00000000) [217uS]
> 00603 : PageStream5 : FAIL =
> Lock("Apps:pgs5058/UserPrefs/KerningData",SHARED) [40uS]
> 00604 : PageStream5 : FAIL =
> Open("Apps:pgs5058/Defaults/KerningData",OLD) = [0x00000000] [92uS]
> 00605 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [33uS]
> 00606 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [206uS]
> 00607 : PageStream5 : FAIL =
> Lock("Apps:pgs5058/UserPrefs/TrackingData",SHARED) [44uS]
> 00608 : PageStream5 : FAIL =
> Open("Apps:pgs5058/Defaults/TrackingData",OLD) = [0x00000000] [70uS]
> 00609 : PageStream5 : o.k. =
> Lock("Apps:pgs5058/SoftLogik/Printers",SHARED) [64uS]
> 00610 : PageStream5 : o.k. = Examine("Printers") [11uS]
> 00611 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:ELF.LazyBinding",SHARED)
> [34uS]
> 00612 : PageStream5 : o.k. =
> LoadSeg_OVL("Apps:pgs5058/SoftLogik/Printers/PostScript.prt",0x00000000,0x00000000)
> = [0x13
> 00613 : PageStream5 : -----> RunCommand(0x13C05C01
> "Apps:pgs5058/SoftLogik/Printers/PostScript.prt",,"",0)
> 00614 : PageStream5 : 0 =
> FindSegmentStackSize("Apps:pgs5058/SoftLogik/Printers/PostScript.prt")
> [500uS]
>
> I use PageStream frequently for minor things, but especially for one small
> but important job each month during the school year. It's time for me to do
> it, but...

2012-08-27 18:07:42 CT #3
admfubar
From: Unknown
Registered: 2011-11-19
Posts: 198

you might just want to rename the pagestream.prefs file to pagestreamold.prefs
no need to rename that whole directory
Smile

On Mon, 27 Aug 2012 18:02:15 -0400, Bart Mathias <mathias@hawaii.edu> wrote:

> All of a sudden my PageStream5.0..5.8 won't launch!
>
> I launched it successfully several times yesterday in attempts to figure out
> how to get it to come up on its own screen instead of Workbench. Later I
> looked at the icon to reconfirm that it had no tooltypes, and tried to
> launch it again. Lots of hard drive activity, which then ceases entirely.
>
> After trying again this morning, I went to look at the debug file, but
> obviously PageStream wasn't through with it yet--I couldn't open, copy, or
> rename it. It did survive a reboot, to my relief, and here is what I found
> at the end:
>
> FT_Done_Face calling
> FT_Done_Face returned
> fontpath_update done
> Duplicate font:TomHud file1:Fonts:_TrueType/TomHud.ttf
> file2:Fonts:_TrueType/TomHudson.ttf
>
> I had saved a debug.txt from October 2010 for some reason, so I compared the
> above with the old one. It too included the above lines near the bottom,
> but in addition there was this:
>
> initapprsrc name:en_US theme:<NULL>
> oldsyskey2newsyskey oldkey:29 -> 80000029
> oldsyskey2newsyskey oldkey:28 -> 80000028
> oldsyskey2newsyskey oldkey:28 -> 80000028
> oldsyskey2newsyskey oldkey:20 -> 80000020
> oldsyskey2newsyskey oldkey:21 -> 80000021
> oldsyskey2newsyskey oldkey:22 -> 80000022
> oldsyskey2newsyskey oldkey:23 -> 80000023
> oldsyskey2newsyskey oldkey:21 -> 80000021
> oldsyskey2newsyskey oldkey:24 -> 80000024
> initapprsrc name:en_US theme:<NULL>
>
> This seems to be a clue as to where the program is conking out, but I can't
> interpret it.
>
> I also ran Snoopy, which ends with:
> 00596 : PageStream5 : o.k. = ExamineFH("DejaVuSansMono-Bold.ttf") [11uS]
> 00597 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [44uS]
> 00598 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [324uS]
> 00599 : PageStream5 : o.k. =
> Lock("Apps:pgs5058/UserPrefs/FontSubstitutionData",SHARED) [91uS]
> 00600 : PageStream5 : o.k. =
> Open("Apps:pgs5058/UserPrefs/FontSubstitutionData",OLD) = [0x142ADAC4]
> [64uS]
> 00601 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [33uS]
> 00602 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957DC,512,0x00000000) [217uS]
> 00603 : PageStream5 : FAIL =
> Lock("Apps:pgs5058/UserPrefs/KerningData",SHARED) [40uS]
> 00604 : PageStream5 : FAIL =
> Open("Apps:pgs5058/Defaults/KerningData",OLD) = [0x00000000] [92uS]
> 00605 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:APPLICATIONDATA",SHARED)
> [33uS]
> 00606 : PageStream5 : FAIL =
> GetVar("APPLICATIONDATA",0x4FB957D8,512,0x00000000) [206uS]
> 00607 : PageStream5 : FAIL =
> Lock("Apps:pgs5058/UserPrefs/TrackingData",SHARED) [44uS]
> 00608 : PageStream5 : FAIL =
> Open("Apps:pgs5058/Defaults/TrackingData",OLD) = [0x00000000] [70uS]
> 00609 : PageStream5 : o.k. =
> Lock("Apps:pgs5058/SoftLogik/Printers",SHARED) [64uS]
> 00610 : PageStream5 : o.k. = Examine("Printers") [11uS]
> 00611 : ENV/env-handler 53.2 : FAIL = Lock("ENVARC:ELF.LazyBinding",SHARED)
> [34uS]
> 00612 : PageStream5 : o.k. =
> LoadSeg_OVL("Apps:pgs5058/SoftLogik/Printers/PostScript.prt",0x00000000,0x00000000)
> = [0x13
> 00613 : PageStream5 : -----> RunCommand(0x13C05C01
> "Apps:pgs5058/SoftLogik/Printers/PostScript.prt",,"",0)
> 00614 : PageStream5 : 0 =
> FindSegmentStackSize("Apps:pgs5058/SoftLogik/Printers/PostScript.prt")
> [500uS]
>
> I use PageStream frequently for minor things, but especially for one small
> but important job each month during the school year. It's time for me to do
> it, but...

2012-08-27 12:35:07 CT #4
Bart Mathias
From: United States
Registered: 2007-01-13
Posts: 320

On 27/08/2012, admfubar@gmail.com wrote:

> here is something to try... find the pagestream configuration dirctory,
> not sure where it is kept on amigas these days... and rename it (like
> pagestreamold
>
> then try launching pagestream, it should come up in demo mode, and if
> it does, that is a good sign, as it is just something in the
> configuration file that is a little wonky.

Thanks you. At least I was able to rule that out. Nothing comes up.

I'm going to try copying the program itself from my old AmigaOne disk
(renaming the current one, of course).

--
Bart Mathias
SAM460ex OS4.1.5


2012-08-27 21:02:09 CT #5
admfubar
From: Unknown
Registered: 2011-11-19
Posts: 198

have you tried starting it from the cli? see if it spits out any error messages there

On Mon, 27 Aug 2012 18:35:07 -0400, Bart Mathias <mathias@hawaii.edu> wrote:

> On 27/08/2012, admfubar@gmail.com wrote:
>
>> here is something to try... find the pagestream configuration dirctory,
>> not sure where it is kept on amigas these days... and rename it (like
>> pagestreamold
>>
>> then try launching pagestream, it should come up in demo mode, and if
>> it does, that is a good sign, as it is just something in the
>> configuration file that is a little wonky.
>
> Thanks you. At least I was able to rule that out. Nothing comes up.
>
> I'm going to try copying the program itself from my old AmigaOne disk
> (renaming the current one, of course).

2012-08-27 15:16:01 CT #6
Bart Mathias
From: United States
Registered: 2007-01-13
Posts: 320

On 27/08/2012, I wrote:

> On 27/08/2012, admfubar@gmail.com wrote:
>
> > here is something to try... find the pagestream configuration
> dirctory, > not sure where it is kept on amigas these days...
> and rename it (like > pagestreamold
> >
> > then try launching pagestream, it should come up in demo mode,
> and if > it does, that is a good sign, as it is just
> something in the > configuration file that is a little
> wonky.
>
> Thanks you. At least I was able to rule that out. Nothing comes up.
>
> I'm going to try copying the program itself from my old AmigaOne disk
> (renaming the current one, of course).

It's getting weirder. I copied the whole PageStream5.0.5.8 drawer over from
my A1 disk and tried running it the app. Up came an "Execute a file"
window, with "PageStream5" in the command line. What the heck, I clicked
"Execute." I had to do an Assign, but up came the program, on Workbench.
Back in my A1 days (through last February), if I remember correctly, I had
always started PageStream from a Shell. Certainly never from an "Execute a
file" window.

But that reminded me. Yesterday when I was looking at Tooltypes in the icon,
I noticed that it had "Start from: Shell" selected. I was mystified, but I
left it that way and clicked the icon. Up came that "Execute a file"
requester. That wasn't right, so I canceled and reset "Start from:" to
"Workbench." And that's when it stopped working, though I didn't suspect
that was why.

So I tried setting the A1 version to "Start from: Workbench," and sure
enough, nothing launched.

I reverted to the PageStream I've been using since March, clicking on the
icon and having PageStream come up on its own screen (until update to
OS4.1.5, when it started coming up scattered here and there on Workbench).
I changed the "Start from:" parameter to "Shell" and clicked the icon, then
"Execute" in the "Execute a file" requester, and gradually PageStream came
up, sort of incognito, on Workbench.

So I can now use PageStream after all, but have two questions instead of
one. The new one is, why all of a sudden did it start coming up with that
"Execute a file" requester yesterday afternoon? Recall that I had opened it
normally (except, on Workbench) just by clicking the icon several times
earlier in the day.

And the first question remains unanswered: How do I get it to open on its
own screen, instead of with its tool bars and edit pallettes hiding among
icons and any open windows on Workbench?
--
Bart Mathias
SAM460ex OS4.1.5


2012-08-27 21:24:31 CT #7
admfubar
From: Unknown
Registered: 2011-11-19
Posts: 198

Looks like some type of tooltype issue... mind you it has been about 20 years since i've used an amiga...


where ther any updates to the amiga os that you've done recently? it may be an issue in the os and how it now handles something.
if there is a screen tooltype for workbench maybe just commenting that tooltype out might will tell pagestream to start on it's own screen..

On Mon, 27 Aug 2012 21:16:01 -0400, Bart Mathias <mathias@hawaii.edu> wrote:

> On 27/08/2012, I wrote:
>

>
> It's getting weirder. I copied the whole PageStream5.0.5.8 drawer over from
> my A1 disk and tried running it the app. Up came an "Execute a file"
> window, with "PageStream5" in the command line. What the heck, I clicked
> "Execute." I had to do an Assign, but up came the program, on Workbench.
> Back in my A1 days (through last February), if I remember correctly, I had
> always started PageStream from a Shell. Certainly never from an "Execute a
> file" window.
>
> But that reminded me. Yesterday when I was looking at Tooltypes in the icon,
> I noticed that it had "Start from: Shell" selected. I was mystified, but I
> left it that way and clicked the icon. Up came that "Execute a file"
> requester. That wasn't right, so I canceled and reset "Start from:" to
> "Workbench." And that's when it stopped working, though I didn't suspect
> that was why.
>
> So I tried setting the A1 version to "Start from: Workbench," and sure
> enough, nothing launched.
>
> I reverted to the PageStream I've been using since March, clicking on the
> icon and having PageStream come up on its own screen (until update to
> OS4.1.5, when it started coming up scattered here and there on Workbench).
> I changed the "Start from:" parameter to "Shell" and clicked the icon, then
> "Execute" in the "Execute a file" requester, and gradually PageStream came
> up, sort of incognito, on Workbench.
>
> So I can now use PageStream after all, but have two questions instead of
> one. The new one is, why all of a sudden did it start coming up with that
> "Execute a file" requester yesterday afternoon? Recall that I had opened it
> normally (except, on Workbench) just by clicking the icon several times
> earlier in the day.
>
> And the first question remains unanswered: How do I get it to open on its
> own screen, instead of with its tool bars and edit pallettes hiding among
> icons and any open windows on Workbench?

Sign in to add a comment Pages: 1
Index » PageStream Support » Amiga » Conked out!

Sign in to add a comment.